Recruitment problems

Terri16

Citizen
  • World: All worlds I have played in
  • In Game Name: all game names I have used
  • Have check the known bugs list: with 25 pages I don’t have the time nor patience to go through them all, a search on recruitment tuned up zero results
  • Have you cleared your cache and cookies: #Yes
  • Have you tried a diffrent computer/laptop/tablelet/phone: #Yes
  • Have you tried a diffrent connection: #Yes
  • Full Version or Mobile Version: #Full - Yes/Mobile# haven’t ever recruited on mobile
  • Browser and Version: Chrome, years of version; Firefox, years of versions, Waterfox, years of versions
  • Overview of the bug: having selected the unit I want to recruit, as I am clicking the checkmark it reverts to the first unit type, example I want to recruit catapults, so I click on catapults, the number I want to recruit s correct, so I go the click the check mark to put the catapults in the que, the catapults are still showing as what I want to recruit, but apparently in the instant that I am clicking, something resets and instead of catapults, swordsmen gets put in the que. The major problem is that now I have lost a bunch of resources when I cancel the order for swords. This also happens in the harbor, try to recruit light ships and instead you put slow transports in the que.
  • How often this occurs: often
  • Work Around: none
 

MarkASp

Peltast
I have the same thing happen regularly. I think it might have to do with accumulating resources changing the number of units available.

Fixing this, along with adding a 5-10 second oops cancel option would be a huge, and simple, enhancement. We've all placed an order, and almost as soon as you hit the check mark, realize it's the wrong thing to recruit (or build), but you only get half the resources back, even if you cancel right away.