Recruit button for heros shows 'recuit troops' instead of just 'recruit'

Volzaac2001

Newcomer
when I looked at the heroes in the recruit section, I realized that the recruit button said recruit troo... ( which I believe is saying recruit troops ). This is only happening in my US account I just made today after the new update. My EN account works normally Some pics about it.

Screenshot 2017-04-21 at 9.25.20 PM.png
EN account
Screenshot 2017-04-21 at 9.25.08 PM.png
US account
  • World: Thebes for US. Kasmenai for EN.
  • In Game Name: Volzaac2001 for both
  • Have check the known bugs list: Yes
  • Have you cleared your cache and cookies: Dont think that will help if it is one but not the other.
  • Have you tried a diffrent computer/laptop/tablet/phone: No. Don't have one
  • Have you tried a diffrent connection: No.
  • Full Version or Mobile Version: Full
  • Browser and Version: Chrome. 57.0.2987.146 64 bit.
  • Overview of the bug: #Bug Details#
  • How often this occurs: Always
  • Work Around: None known
 
Last edited: